Cisco Vlan dan Subinterface

Vlan adalah mekanisme yang dipergunakan untuk membuat logical switching dalam satu switch fisik yang ada.  Kegunaan vlan adalah biasanya adalah untuk membagi area network untuk masing – masing divisi pada suatu perusahaan.  Pada dasarnya client pada group vlan satu tidak bisa berkomunikasi dengan client pada group vlan yang lain, tapi pada prakteknya suatu vlan harus bisa berkomunikasi dengan vlan lain contohnya antara vlan divisi dengan vlan pada group server.  Dengan adanya kondisi seperti itu maka diperlukan Router yang memiliki fitur subinterface untuk memungkinkan terjadinya intervlan communication.  Di bawah ini merupakan contoh topology network vlan dengan menggunakan subinterface.

Pada Topology di atas dalam satu Core Switch terkoneksi beberapa client komputer.  Client – client komputer tersebut dikelompokan dalam beberapa group divisi (Finance, SDM, Marketing, Server).  Dengan pengelompokan tersebut tentunya dibutuhkan mekanisme vlan untuk melakukan grouping pada Core Switch.  Tentunya client – client pada divisi Finance, SDM, Marketing harus dapat mengakses pada vlan Server sehingga dibutuhkan mekanisme intervlan communication sehingga dibutuhkan perangkat Core Router seperti di atas.  Pada Router diaktifkan fitur subinterface sehingga vlan dapat berkomunikasi satu sama lain.

Berikut merupakan konfigurasi pada Core Switch :

— Membuat 4 vlan yaitu vlan 3 (server), vlan 101 (Finance), vlan 102 (HR), vlan 103 (Marketing) —

CoreSwitch>enable
CoreSwitch#configure terminal
CoreSwitch(config)#vlan 3
CoreSwitch(config-vlan)#name Vlan_Server
CoreSwitch(config-vlan)#exit
CoreSwitch(config)#vlan 101
CoreSwitch(config-vlan)#name Vlan_Finance
CoreSwitch(config-vlan)#exit
CoreSwitch(config)#vlan 102
CoreSwitch(config-vlan)#name Vlan_HR
CoreSwitch(config-vlan)#exit
CoreSwitch(config)#vlan 103
CoreSwitch(config-vlan)#name Vlan_Marketing
CoreSwitch(config-vlan)#exit
CoreSwitch(config)#

— Melakukan grouping interface pada switch ke dalam vlan yang ditentukan —

CoreSwitch(config)#interface fastEthernet 0/1
CoreSwitch(config-if)#switchport mode access
CoreSwitch(config-if)#switchport access vlan 101
CoreSwitch(config-if)#exit
CoreSwitch(config)#interface fastEthernet 0/2
CoreSwitch(config-if)#switchport mode access
CoreSwitch(config-if)#switchport access vlan 101
CoreSwitch(config-if)#exit
CoreSwitch(config)#interface fastEthernet 0/3
CoreSwitch(config-if)#switchport mode access
CoreSwitch(config-if)#switchport access vlan 102
CoreSwitch(config-if)#exit
CoreSwitch(config)#interface fastEthernet 0/4
CoreSwitch(config-if)#switchport mode access
CoreSwitch(config-if)#switchport access vlan 102
CoreSwitch(config-if)#exit
CoreSwitch(config)#interface fastEthernet 0/5
CoreSwitch(config-if)#switchport mode access
CoreSwitch(config-if)#switchport access vlan 103
CoreSwitch(config-if)#exit
CoreSwitch(config)#interface fastEthernet 0/6
CoreSwitch(config-if)#switchport mode access
CoreSwitch(config-if)#switchport access vlan 103
CoreSwitch(config-if)#exit
CoreSwitch(config)#interface fastEthernet 0/7
CoreSwitch(config-if)#switchport mode access
CoreSwitch(config-if)#switchport access vlan 3
CoreSwitch(config-if)#exit
CoreSwitch(config)#interface fastEthernet 0/8
CoreSwitch(config-if)#switchport mode access
CoreSwitch(config-if)#switchport access vlan 3
CoreSwitch(config-if)#exit
CoreSwitch(config)#exit
CoreSwitch#write

command switchport mode access dimaksudkan agar interface tersebut tergolong dalam mode akses yaitu interface yang berhubungan dengan client network device.

command switchport access vlan … adalah menggolongkan bahwa interface tersebut tergolong dalam vlan tertentu

command write dipergunakan untuk menyimpan configurasi dari running configuration ke startup configuration

Pada tahap ini setiap client hanya dapat melakukan akses network antar client dalam group vlan yang sama saja (test bisa dilakukan dengan ping ip komputer).

Kemudian dilanjutkan dengan konfigurasi router seperti di bawah ini :

CoreRouter>enable
CoreRouter#configure terminal
CoreRouter(config)#interface fastEthernet 0/0.1
CoreRouter(config-subif)#encapsulation dot1Q 101
CoreRouter(config-subif)#ip address 10.1.101.1 255.255.255.0
CoreRouter(config-subif)#exit
CoreRouter(config)#interface fastEthernet 0/0.2
CoreRouter(config-subif)#encapsulation dot1Q 102
CoreRouter(config-subif)#ip address 10.1.102.1 255.255.255.0
CoreRouter(config-subif)#exit
CoreRouter(config)#interface fastEthernet 0/0.3
CoreRouter(config-subif)#encapsulation dot1Q 103
CoreRouter(config-subif)#ip address 10.1.103.1 255.255.255.0
CoreRouter(config-subif)#exit
CoreRouter(config)#interface fastEthernet 0/0.4
CoreRouter(config-subif)#encapsulation dot1Q 3
CoreRouter(config-subif)#ip address 10.1.3.1 255.255.255.0
CoreRouter(config-subif)#exit
CoreRouter(config)#exit
CoreRouter#write

asumsi port CoreRouter yang terkoneksi dengan port CoreSwitch ada di port fastEthernet 0/0 pada CoreRouter.
Kemudian dengan menggunakan command interface fastEthernet 0/0.x dimana x adalah angka subinterface.  Subinterface adalah interface virtual yang diturunkan dari interface fisik.
Setelah masuk ke dalam konfigurasi subinterface kemudian kita ketik command encapsulation dot1Q x dimana x adalah nomor vlan.  Dengan menggunakan command ini berarti kita melakukan mapping subinterface terhadap vlan tertentu.
Kemudian setelah itu kita menentukan ip address dengan command ip address 10.1.x.1 255.255.255.0 sehingga ip ini akan dipergunakan juga sebagai ip gateway dari masing – masing client PC pada group vlan yang termapping dalam subinterface itu.

Sampai disini konfigurasi CoreSwitch dan CoreRouter telah selesai dilakukan.  Untuk melakukan pengetasan bisa dilakukan dengan menggunakan command ping di PC Client.  Dengan adanya konfigurasi subinterface maka akan terjadi proses intervlan communication dimana pada kondisi awal vlan tidak dapat berkomunikasi dengan vlan lain, tetapi dengan telah dikonfigurasinya subinterface maka antar group dalam vlan tertentu dapat berkomunikasi dengan client pada group vlan yang lainnya.

Pertanyaannya bagaimana untuk membatasi akses agar client PC divisi satu tidak bisa berkomunikasi dengan divisi lain tetapi vlan server masih dapat diakses melalui divisi – divisi yang ada.  Jawabannya adalah pembatasan akses dengan menggunakan metode Access List yang akan dibahas pada artikel selanjutnya.

a simple man

Tagged with: , ,
Posted in Knowledge

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

November 2011
M T W T F S S
« Dec   Feb »
 123456
78910111213
14151617181920
21222324252627
282930  
Blog Stats
  • 72,745 hits
%d bloggers like this: